[ceph-users] iSCSI: tcmu-runner can't open images?

Jason Dillaman jdillama at redhat.com
Fri Nov 3 06:27:37 PDT 2017


On Fri, Nov 3, 2017 at 9:05 AM, Matthias Leopold <
matthias.leopold at meduniwien.ac.at> wrote:

>
>
> Am 2017-11-03 um 02:44 schrieb Jason Dillaman:
>
>> On Thu, Nov 2, 2017 at 11:34 AM, Matthias Leopold <
>> matthias.leopold at meduniwien.ac.at <mailto:matthias.leopold at medun
>> iwien.ac.at>> wrote:
>>
>>     Hi,
>>
>>     i'm trying to set up iSCSI gateways for a Ceph luminous cluster
>>     using these instructions:
>>     http://docs.ceph.com/docs/master/rbd/iscsi-target-cli/
>>     <http://docs.ceph.com/docs/master/rbd/iscsi-target-cli/>
>>
>>     When arriving at step "Configuring: Adding a RADOS Block Device
>>     (RBD)" things start to get messy: there is no "disks" entry in my
>>     target path, so i can't "cd /iscsi-target/iqn.2003-01.com
>>     <http://iqn.2003-01.com>.redhat.iscsi-gw:<target_name>/disks/". When
>>     i try to create a disk in the top level "/disks" path ("/disks>
>>     create pool=ovirt-default image=itest04 size=50g") gwcli crashes
>>     with "ValueError: No JSON object could be decoded" (there is more
>>     output when using debug but i don't think it matters). More
>>     interesting is /var/log/tcmu-runner.log, it says consistently
>>
>>     [DEBUG] handle_netlink:207: cmd 1. Got header version 2. Supported 2.
>>     [DEBUG] dev_added:768 rbd/ovirt-default.itest04: Got block_size 512,
>>     size in bytes 53687091200
>>     [DEBUG] tcmu_rbd_open:581 rbd/ovirt-default.itest04: tcmu_rbd_open
>>     config rbd/ovirt-default/itest04/osd_op_timeout=30 block size 512
>>     num lbas 104857600.
>>     [DEBUG] timer_check_and_set_def:234 rbd/ovirt-default.itest04: The
>>     cluster's default osd op timeout(30.000000), osd heartbeat grace(20)
>>     interval(6)
>>     [DEBUG] timer_check_and_set_def:242 rbd/ovirt-default.itest04: The
>>     osd op timeout will remain the default value: 30.000000
>>     [ERROR] tcmu_rbd_image_open:318 rbd/ovirt-default.itest04: Could not
>>     open image itest04/osd_op_timeout=30. (Err -2)
>>
>>
>> The error is that ceph-iscsi-config has instructed tcmu-runner that the
>> name of the image is "itest04/osd_op_timeout=30". We changed the delimiter
>> for separating optionals from "/" to ";" and that is what your version of
>> tcmu-runner is expecting. Upgrade to the latest available version of
>> ceph-iscsi-config from here [1].
>>
>
> thank you very much, now this problem is gone and i happily run into the
> "missing kernel attribute: qfull_time_out" issue ;-)
>
> i read your comments in https://bugzilla.redhat.com/sh
> ow_bug.cgi?id=1503711 and the http://lists.ceph.com/pipermai
> l/ceph-users-ceph.com/2017-November/022042.html thread, so i guess i'll
> have to wait for newer upstream and subsequently RHEL/CentOS kernels. i can
> only say we would be very happy if these patches could already be included
> in the 7.4.z kernels.
>

This is a 4.14-rc7 kernel w/ Mike's patches applied [1] if you wanted to
play.


> one minor issue i noticed is that gwcli doesn't like hyphens in pool
> names. i don't know if this check is really necessary, we just happen to
> have hyphens in our pool names, so we would have to change that
>

That should hopefully be fixed by this PR [2] once it's merged (haven't had
a chance to test it yet).


> thanks a lot for your good work
> matthias
>
>
>

[1]
https://shaman.ceph.com/repos/kernel/wip-jd-testing/8cdb3dd6d6843e1c19844945671b261143d714eb/default/58594/
[2] https://github.com/ceph/ceph-iscsi-cli/pull/41

-- 
Jason
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ceph.com/pipermail/ceph-users-ceph.com/attachments/20171103/bc987046/attachment.html>


More information about the ceph-users mailing list