[ceph-users] Fwd: Luminous RadosGW issue

Sam Huracan nowitzki.sammy at gmail.com
Wed Nov 8 20:25:47 PST 2017


@Hans: Yes, I tried to redeploy RGW, and ensure client.radosgw.gateway is
the same in ceph.conf.
Everything go well, service radosgw running, port 7480 is opened, but all
my config of radosgw in ceph.conf can't be set, rgw_dns_name is still
empty, and log file keeps default value.

[root at radosgw system]# ceph --admin-daemon
/var/run/ceph/ceph-client.rgw.radosgw.asok config show | grep log_file
    "log_file": "/var/log/ceph/ceph-client.rgw.radosgw.log",


[root at radosgw system]# cat /etc/ceph/ceph.client.radosgw.keyring
[client.radosgw.gateway]
        key = AQCsywNaqQdDHxAAC24O8CJ0A9Gn6qeiPalEYg==
        caps mon = "allow rwx"
        caps osd = "allow rwx"


2017-11-09 6:11 GMT+07:00 Hans van den Bogert <hansbogert at gmail.com>:

> Are you sure you deployed it with the client.radosgw.gateway name as
> well? Try to redeploy the RGW and make sure the name you give it
> corresponds to the name you give in the ceph.conf. Also, do not forget
> to push the ceph.conf to the RGW machine.
>
> On Wed, Nov 8, 2017 at 11:44 PM, Sam Huracan <nowitzki.sammy at gmail.com>
> wrote:
> >
> >
> > Hi Cephers,
> >
> > I'm testing RadosGW in Luminous version.  I've already installed done in
> separate host, service is running but RadosGW did not accept any my
> configuration in ceph.conf.
> >
> > My Config:
> > [client.radosgw.gateway]
> > host = radosgw
> > keyring = /etc/ceph/ceph.client.radosgw.keyring
> > rgw socket path = /var/run/ceph/ceph.radosgw.gateway.fastcgi.sock
> > log file = /var/log/radosgw/client.radosgw.gateway.log
> > rgw dns name = radosgw.demo.com
> > rgw print continue = false
> >
> >
> > When I show config of radosgw socket:
> > [root at radosgw ~]# ceph --admin-daemon /var/run/ceph/ceph-client.rgw.radosgw.asok
> config show | grep dns
> >     "mon_dns_srv_name": "",
> >     "rgw_dns_name": "",
> >     "rgw_dns_s3website_name": "",
> >
> > rgw_dns_name is empty, hence S3 API is unable to access Ceph Object
> Storage.
> >
> >
> > Do anyone meet this issue?
> >
> > My ceph version I'm  using is ceph-radosgw-12.2.1-0.el7.x86_64
> >
> > Thanks in advance
> >
> >
> > _______________________________________________
> > ceph-users mailing list
> > ceph-users at lists.ceph.com
> > http://lists.ceph.com/listinfo.cgi/ceph-users-ceph.com
> >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ceph.com/pipermail/ceph-users-ceph.com/attachments/20171109/ed1d5d51/attachment.html>


More information about the ceph-users mailing list