[ceph-users] No ops on some OSD

John Spray jspray at redhat.com
Mon Nov 13 02:48:12 PST 2017


On Sun, Nov 12, 2017 at 2:56 PM, Marc Roos <M.Roos at f1-outsourcing.eu> wrote:
>
> [@c03 ~]# ceph osd status
> 2017-11-12 15:54:13.164823 7f478a6ad700 -1 WARNING: the following
> dangerous and experimental features are enabled: bluestore
> 2017-11-12 15:54:13.211219 7f478a6ad700 -1 WARNING: the following
> dangerous and experimental features are enabled: bluestore
> no valid command found; 10 closest matches:
> osd map <poolname> <objectname> {<nspace>}
> osd lspools {<int>}
> osd count-metadata <property>
> osd versions
> osd find <osdname (id|osd.id)>
> osd metadata {<osdname (id|osd.id)>}
> osd getmaxosd
> osd ls-tree {<int[0-]>} {<name>}
> osd getmap {<int[0-]>}
> osd getcrushmap {<int[0-]>}
> Error EINVAL: invalid command

The "osd status" command comes from the ceph-mgr module called
"status" -- this is enabled by default but it's possible that it got
switched off on your system?  Check your ceph-mgr logs and whether
it's in "ceph mgr module ls" (or try enabling with "ceph mgr module
enable status")

John

>
>
>
> -----Original Message-----
> From: I Gede Iswara Darmawan [mailto:iswaradrmwn at gmail.com]
> Sent: zondag 12 november 2017 2:17
> Cc: ceph-users
> Subject: Re: [ceph-users] No ops on some OSD
>
> Still the same syntax (ceph osd status)
>
> Thanks
>
> Regards,
>
> I Gede Iswara Darmawan
>
> Information System - School of Industrial and System Engineering
>
> Telkom University
>
> P / SMS / WA : 081 322 070719
>
> E : iswaradrmwn at gmail.com / iswaradrmwn at live.com
>
>
> On Sat, Nov 4, 2017 at 6:11 PM, Marc Roos <M.Roos at f1-outsourcing.eu>
> wrote:
>
>
>
>
>         What is the new syntax for "ceph osd status" for luminous?
>
>
>
>
>
>         -----Original Message-----
>         From: I Gede Iswara Darmawan [mailto:iswaradrmwn at gmail.com]
>         Sent: donderdag 2 november 2017 6:19
>         To: ceph-users at lists.ceph.com
>         Subject: [ceph-users] No ops on some OSD
>
>         Hello,
>
>         I want to ask about my problem. There's some OSD that dont have any
> load
>         (indicated with No ops on that OSD).
>
>         Hereby I attached the ceph osd status result :
>         https://pastebin.com/fFLcCbpk . Look at OSD 17,61 and 72. There's
> no
>         load or operation happened at that OSD. How to fix this?
>
>         Thank you
>         Regards,
>
>         I Gede Iswara Darmawan
>
>         Information System - School of Industrial and System Engineering
>
>         Telkom University
>
>         P / SMS / WA : 081 322 070719
>
>         E : iswaradrmwn at gmail.com / iswaradrmwn at live.com
>
>
>
>
>         _______________________________________________
>         ceph-users mailing list
>         ceph-users at lists.ceph.com
>         http://lists.ceph.com/listinfo.cgi/ceph-users-ceph.com
> <http://lists.ceph.com/listinfo.cgi/ceph-users-ceph.com>
>
>
>
>
> _______________________________________________
> ceph-users mailing list
> ceph-users at lists.ceph.com
> http://lists.ceph.com/listinfo.cgi/ceph-users-ceph.com


More information about the ceph-users mailing list