[ceph-users] Problem activating osd's

de Witt, Shaun shaun.de-witt at ukaea.uk
Thu Nov 16 08:14:14 PST 2017


Hi

I have searched the threads for a resolution to this problem, but so far have had no success.

First – my setup.  I am trying to replicate the setup on the quick ceph-deploy pages.  I have 4 virtual machines (virtualbox running SL7.3 – a CentOS clone).  Iptables is not running on any nodes.  Passwordless ssh works.  I have done an md5 comparison between what I think are the correct keyrings and that all looks good.  Host machine is a mac…

So…
Everything seems to go fine up until the point where I try and activate the osds.  From the manual, I run

ceph-deploy osd activate {ceph-node}:/path/to/directory

It then tries to run
/usr/bin/ceph –cluster ceph –name client.bootstrap-osd –keyring /var/lib/ceph/bootstrap-osd/ceph.keyring osd create –concise <some UUID>

and then reports
No data received after 300 seconds, disconnecting…


So I also tried to run this directly on the osd node I get various messages of the form
<date> <time> 7fa6ec6dc700 0 -- :/1962043722 >> 10.209.2.65:6789/0 pipe(0x<hexNumber> sd=3 :0 s=1 pgs=0 cs=0 l=1 c=0x<hux number>).fault

And ends with
Monclient(hunting): authentication timed out after 300
Librados: client.bootstrap-osd authentication error (11) Connection timed out

I read on one of the responses that jumbo frames may be the issue but I have no idea if this is correct or how to fix it if it is.  Any other suggestions?

Cheers

HungMung
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ceph.com/pipermail/ceph-users-ceph.com/attachments/20171116/5a8df1bf/attachment.html>


More information about the ceph-users mailing list