[ceph-users] Can't remove pg on bluestore

Shawn Edwards lesser.evil at gmail.com
Wed Nov 22 15:04:08 PST 2017


I have a pg that is 'incomplete'.  I've tried using ceph-objectstore-tool
to export/import using a clean osd, and I get a crash in the import.

No biggie, the data on that particular pg isn't critical enough that I need
to panic over it, so I tried stopping the osds, doing ceph-objectstore-tool
--op remove on all osd with the pg on it, restarting the osds, then calling
'ceph osd force-create-pg xxx' to get a new, clean pg back.  The pg still
shows as incomplete.

I've had to do remove incomplete pg in testing before, but only with
filestore osd.  This is the first time I've had to do this with a bluestore
osd (the primary, in this case).  Is there anything different for
bluestore, or am I doing something fundamentally wrong here?

Since a single incomplete pg will hose the whole cluster, I'm dead until I
can figure this out.  Any and all help appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ceph.com/pipermail/ceph-users-ceph.com/attachments/20171122/6b1219d3/attachment.html>


More information about the ceph-users mailing list