[ceph-users] ceph osd after xfs repair only 50 percent data and osd won't start

David Turner drakonstein at gmail.com
Sun Nov 26 08:09:39 PST 2017


If you are too a point where you need to repair the xfs partition, you
should probably just rebuild the osd and backfill back onto it as a fresh
osd. That's even more true now that the repair had bad side effects.

On Sat, Nov 25, 2017, 11:33 AM Hauke Homburg <hhomburg at w3-creative.de>
wrote:

> Hello List,
>
> Yesterday i repaired a Partition with an osd. I flushed and recreated
> the yournal. After This i saw that i only have 50 Percent of Data in the
> OSD. Now the OSD Daemon will not start. An enable of the Debug brings
>
> ceph tell osd.0 injectargs --debug-osd 0/5
> Error ENXIO: problem getting command descriptions from osd.0
>
> The last Log Entry of the osd:
>
> 2017-11-25 15:22:00.351424 7f146f95b800  1 journal check: header looks ok
> 2017-11-25 15:22:00.351433 7f146f95b800  1 journal close
> /var/lib/ceph/osd/ceph-0/journal
> 2017-11-25 15:22:00.351514 7f146f95b800 -1 created new journal
> /var/lib/ceph/osd/ceph-0/journal for object store /var/lib/ceph/osd/ceph-0
>
> i have set ceph osd noout.
>
> Can anybody help me to start the OSD Daemon? I guess the OSD daesn't
> start because the OSD has only 50% Data. IS this correct? How can i
> repair this? I tried unset noout but after this the OSD Crashed, too
>
> Hauke
>
> --
> www.w3-creative.de
>
> www.westchat.de
>
> https://friendica.westchat.de/profile/hauke
>
> _______________________________________________
> ceph-users mailing list
> ceph-users at lists.ceph.com
> http://lists.ceph.com/listinfo.cgi/ceph-users-ceph.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ceph.com/pipermail/ceph-users-ceph.com/attachments/20171126/73fd0f0d/attachment.html>


More information about the ceph-users mailing list