[ceph-users] Ceph Influx Plugin in luminous

mart.v mart.v at seznam.cz
Mon Nov 12 03:54:27 PST 2018


Hi,



I'm trying to set up a Influx plugin (http://docs.ceph.com/docs/mimic/mgr/
influx/). The docs says that it will be available in Mimic release, but I 
can see it (and enable) in current Luminous. It seems that someone else 
acutally used it in Luminous (http://lists.ceph.com/pipermail/ceph-users-
ceph.com/2018-January/023864.html):





# ceph mgr module ls

{

    "enabled_modules": [

        "balancer",

        "dashboard",

        "influx",

        "restful",

        "status"

    ],

    "disabled_modules": [

        "localpool",

        "prometheus",

        "selftest",

        "zabbix"

    ]

}




I tried the most simple setup (local influxdb without SSL) and configured 
plugin this way:





# ceph influx config-show

{"username": "ceph", "database": "ceph", "hostname": "localhost", "ssl": 
false, "verify_ssl": false, "password": "*****", "port": 8086}





Influx is accessible and running. There are no messages in logs but also no 
measurements in influxdb. Running "ceph influx self-test" produces 
reasonable output.




(I also tried to connect the plugin to our remote influxdb, same result.




Any ideas?




Thanks! 

Martin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ceph.com/pipermail/ceph-users-ceph.com/attachments/20181112/3a6b6502/attachment.html>


More information about the ceph-users mailing list