[ceph-users] Automated Deep Scrub always inconsistent

Jonas Jelten jelten at in.tum.de
Mon Nov 12 07:56:44 PST 2018


Maybe you are hitting the kernel bug worked around by https://github.com/ceph/ceph/pull/23273

-- Jonas


On 12/11/2018 16.39, Ashley Merrick wrote:
> Is anyone else seeing this?
> 
> I have just setup another cluster to check on completely different hardware and everything running EC still.
> 
> And getting inconsistent PG’s flagged after an auto deep scrub which can be fixed by just running another deep-scrub.
> 
> On Thu, 8 Nov 2018 at 4:23 PM, Ashley Merrick <singapore at amerrick.co.uk <mailto:singapore at amerrick.co.uk>> wrote:
> 
>     Have in the past few days noticed that every single automated deep scrub comes back as inconsistent, once I run a
>     manual deep-scrub it finishes fine and the PG is marked as clean.
> 
>     I am running the latest mimic but have noticed someone else under luminous is facing the same issue
>http://lists.ceph.com/pipermail/ceph-users-ceph.com/2018-November/031166.html
> 
>     I don't believe this is any form of hardware failure as every time it is different OSD's and every time a manual
>     started deep-scrub finishes without issue.
> 
>     Is there something that was released in the most recent mimic and luminous patches that could be linked to this? Is
>     it somehow linked with the main issue with the 12.2.9 release?


More information about the ceph-users mailing list