[ceph-users] Luminous v12.2.10 released

Josh Durgin jdurgin at redhat.com
Tue Nov 27 12:11:56 PST 2018


On 11/27/18 8:26 AM, Simon Ironside wrote:
> On 27/11/2018 14:50, Abhishek Lekshmanan wrote:
>>
>> We're happy to announce the tenth bug fix release of the Luminous
>> v12.2.x long term stable release series. The previous release, v12.2.9,
>> introduced the PG hard-limit patches which were found to cause an issue
>> in certain upgrade scenarios, and this release was expedited to revert
>> those patches. If you already successfully upgraded to v12.2.9, you
>> should **not** upgrade to v12.2.10, but rather **wait** for a release in
>> which http://tracker.ceph.com/issues/36686 is addressed. All other users
>> are encouraged to upgrade to this release.
> 
> Is it safe for v12.2.9 users upgrade to v13.2.2 Mimic?
> 
> http://tracker.ceph.com/issues/36686 suggests a similar revert might be 
> on the cards for v13.2.3 so I'm not sure.

Yes, 13.2.2 has the same pg hard limit code as 12.2.9, so that upgrade
is safe. The only danger is running a mixed-version cluster where some
of the osds have the pg hard limit code, and others do not.

13.2.3 will have a similar revert, so if you are running anything other
than 12.2.9 or 13.2.2 you can go directly to 13.2.3.

Josh


More information about the ceph-users mailing list