[ceph-users] Don't upgrade to 13.2.2 if you use cephfs

Patrick Donnelly pdonnell at redhat.com
Mon Oct 8 09:50:59 PDT 2018


+ceph-announce

On Sun, Oct 7, 2018 at 7:30 PM Yan, Zheng <ukernel at gmail.com> wrote:
> There is a bug in v13.2.2 mds, which causes decoding purge queue to
> fail. If mds is already in damaged state, please downgrade mds to
> 13.2.1, then run 'ceph mds repaired fs_name:damaged_rank' .
>
> Sorry for all the trouble I caused.
> Yan, Zheng

This issue is being tracked here: http://tracker.ceph.com/issues/36346

The problem was caused by a backport of the wrong commit which
unfortunately was not caught. The backport was not done to Luminous;
only Mimic 13.2.2 is affected. New deployments on 13.2.2 are also
affected but do not require immediate action. A procedure for handling
upgrades of fresh deployments from 13.2.2 to 13.2.3 will be included
in the release notes for 13.2.3.
-- 
Patrick Donnelly


More information about the ceph-users mailing list