[ceph-users] Does anyone use interactive CLI mode?

Eugen Block eblock at nde.ag
Thu Oct 11 02:00:50 PDT 2018


I only tried to use the Ceph CLI once out of curiosity, simply because  
it is there, but I don't really benefit from it.
Usually when I'm working with clusters it requires a combination of  
different commands (rbd, rados, ceph etc.), so this would mean either  
exiting and entering the CLI back and forth or switching between  
different terminal windows/tabs. Running all the necessary commands  
from the same terminal is much more comfortable and auto completion  
makes it even easier.
That's why I join the previous comments, I wouldn't mind if the CLI  
would be removed.

Regards,
Eugen


Zitat von Brady Deetz <bdeetz at gmail.com>:

> I run 2 clusters and have never purposely executed the interactive cli. I
> save remove the code bloat.
>
> On Wed, Oct 10, 2018 at 9:20 AM John Spray <jspray at redhat.com> wrote:
>
>> Hi all,
>>
>> Since time immemorial, the Ceph CLI has had a mode where when run with
>> no arguments, you just get an interactive prompt that lets you run
>> commands without "ceph" at the start.
>>
>> I recently discovered that we actually broke this in Mimic[1], and it
>> seems that nobody noticed!
>>
>> So the question is: does anyone actually use this feature?  It's not
>> particularly expensive to maintain, but it might be nice to have one
>> less path through the code if this is entirely unused.
>>
>> Cheers,
>> John
>>
>> 1. https://github.com/ceph/ceph/pull/24521
>> _______________________________________________
>> ceph-users mailing list
>> ceph-users at lists.ceph.com
>> http://lists.ceph.com/listinfo.cgi/ceph-users-ceph.com
>>





More information about the ceph-users mailing list