[ceph-users] Ceph osd logs

Zhenshi Zhou deaderzzs at gmail.com
Thu Oct 18 20:03:21 PDT 2018


Hi Massimo,

I checked the ownership of the file as well as the log directory.
The files' ownership are ceph with permission 644. Besides, the
log directory's ownership is ceph and the permission is 'drwxrws--T'

I suppose that the ownership and file permission are enough for
ceph to write logs.

Thanks

Massimo Sgaravatto <massimo.sgaravatto at gmail.com> 于2018年10月18日周四 下午11:40写道:

> I had the same  problem (or a problem with the same symptoms)
> In my case the problem was with wrong ownership of the log file
> You might want to check if you are having the same issue
>
> Cheers, Massimo
>
> On Mon, Oct 15, 2018 at 6:00 AM Zhenshi Zhou <deaderzzs at gmail.com> wrote:
>
>> Hi,
>>
>> I added some OSDs into cluster(luminous) lately. The osds use
>> bluestoreand everything goes fine. But there is no osd log in the
>> log file. The log directory has only empty files.
>>
>> I check my settings, "ceph daemon osd.x config show", and I get
>> "debug_osd": "1/5".
>>
>> How can I get the new osds' logs?
>> _______________________________________________
>> ceph-users mailing list
>> ceph-users at lists.ceph.com
>> http://lists.ceph.com/listinfo.cgi/ceph-users-ceph.com
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ceph.com/pipermail/ceph-users-ceph.com/attachments/20181019/44ac7a74/attachment.html>


More information about the ceph-users mailing list