[ceph-users] Disabling RGW Encryption support in Luminous

Arvydas Opulskis zebediejus at gmail.com
Thu Oct 18 23:39:56 PDT 2018


Hi, yes we did it two days ago too. There is PR for this, but it's not
commited yet.
Thanks, anyway!

Arvydas

On Fri, Oct 19, 2018 at 7:15 AM Konstantin Shalygin <k0ste at k0ste.ru> wrote:

> After RGW upgrade from Jewel to Luminous, one S3 user started to receive
> errors from his postgre wal-e solution. Error is like this: "Server Side
> Encryption with KMS managed key requires HTTP header
> x-amz-server-side-encryption : aws:kms".
>
> This can be resolved via simple patch of wal-e/wal-g. I was already make a
> patch for our pgsql guys.
>
> And don't know was this patch upstreamed or not. If this still need to
> someone I can make a Github PR for this.
>
>
>
> k
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ceph.com/pipermail/ceph-users-ceph.com/attachments/20181019/7ebb4efb/attachment.html>


More information about the ceph-users mailing list