<div dir="ltr">Here's where we are now.<div><br></div><div>By cherry-picking that patch into ceph-iscsi-config tags/v2.6 and cleaning up the merge conflicts, the rbd-target-gw service would not start.</div><div><br></div><div>With the release of ceph-iscsi-config v2.6 (no cherry picked commits) and tcmu-runner v1.3.0 the originally described errors still exist.</div><div><br></div><div>Is there a known working combination of releases of trslib-fb, targetcli-fb, ceph-iscsi-config, ceph-iscsi-cli, and tcmu-runner?</div></div><br><div class="gmail_quote"><div dir="ltr">On Wed, Oct 10, 2018 at 1:31 PM Mike Christie <<a href="mailto:mchristi@redhat.com">mchristi@redhat.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">On 10/10/2018 01:13 PM, Brady Deetz wrote:<br>
> ceph-iscsi-config v2.6 <a href="https://github.com/ceph/ceph-iscsi-config.git" rel="noreferrer" target="_blank">https://github.com/ceph/ceph-iscsi-config.git</a><br>
<br>
....<br>
<br>
>     Ignore that. ceph-iscsi-config 2.6 enabled explicit alua in anticipation<br>
>     for the tcmu-runner support. We are about to release 2.7 which matches<br>
>     tcmu-runner 1.4.0.<br>
> <br>
<br>
You need this patch which sets the failover type back to implicit to<br>
match tcmu-runner 1.4.0 and also makes it configurable for future versions:<br>
<br>
commit 8d66492b8c7134fb37b72b5e8e77d7c8109220d9<br>
Author: Mike Christie <<a href="mailto:mchristi@redhat.com" target="_blank">mchristi@redhat.com</a>><br>
Date:   Mon Jul 23 15:45:09 2018 -0500<br>
<br>
    Allow alua failover type to be configurable<br>
<br>
in the ceph-iscsi-config git tree master branch. It will be in<br>
ceph-iscsi-config 2.7 that we are trying to finish up by Friday.<br>
</blockquote></div>